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1.0 RUNNING THE PROGRAMMING SOFTWARE

The software is provided on the supplied Micro SD card and is called “A4510TimerProgrammer_xxxx.exe”.

In order to access the program, the Micro SD card will need to be connected to a Windows based device such as a PC or 
laptop. It will need to be equipped with an Micro SD card reader to do this. If an SD slot is not available then the D 0371
A USB Memory Card Reader or similar would be suitable (not supplied). 

You will first need to remove power from the A 4510B and then remove the Micro SD card from the front of the unit. 
To remove the Micro SD card push the card in and it will eject itself. 

Make sure the Windows based device is 
on and card reader connected and correct-
ly installed. Then insert the Micro SD card 
into the reader. 
Go to “My Computer” or “This PC” and 
open the Micro SD card which is usually 
marked “Removable disk”. 
In this case it is named “Removable disk 
(K:)”. Select the removable disk and then 
you should get a window that looks like 
figure 1.
It is recommended to run the program 
from the Micro SD card. 
Double click on the file - A4510TimerPro-
grammer.exe 
The programming screen should appear as 
shown in Fig 2. If the program doesn’t run 
then the .NET Framework might 
need to be updated on your PC. This must 
be updated to the .NET Framework 4,  
available on the microsoft website.
    Fig 1

 Fig 2 
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If this is the first time the program has been run, a new calendar will need to be created. Navigate to the “File” menu in the 
top left corner and select “New”.
The window shown below will appear. The start and end dates will default to the current year with a 2 month overlap into 
the following year. 
NOTE: The calendar start and end dates can be set to a minimum of 1 month, up to a maximum of 2 years.

In our example we will select the default calendar.
Press “OK” to confirm the dates. The window shown in figure 3 should be created. 
This is where all the timing information will be entered for the calendar year.
NOTE: The colour scheme for the calendar can be altered in the defult setup (refer to section 4.0 for more information).

Fig 3
2.0 ADDING AN EVENT GROUP 

The software makes it very easy to enter the timing events for any calendar day. The timing events for a day can be grouped  
and labelled into something meaningful to the user, such as “StandardDay”, “PublicHols”, “SchoolHols”, “StudtFreeDay”, 
“AssemblyDay”, etc up to a maximum of 12 characters.
To add a group, simply press the “ADD” button in the Event Groups section of the window. The window shown below 
should appear.
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For our example we are going to start by adding the event group labelled “StandardDay”.
NOTE: No spaces or special characters can be used when creating the labels. 
Enter the label, select a colour for the visuall representation of the day on the calendar as shown below and then press “OK”.

The Event Group created will now appear in the Event Groups as shown in figure 4.

Fig 4

Before we go any further we will save the calendar configuration. Navigate to the “File” menu in the top left corner and 
select “Save”. 

We will now create the other groups we would like to add. 
We will add Event Groups for public holidays labelled “PublicHols” and an Event Group for school holidays labelled 
“SchoolHols”. We can do this by following the same procedure just outlined or we can use the “Duplicate Event Group” 
option (see section 6.0 for more details).
The result is shown in figure 5.

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the Micro SD card, so all configuration information will be saved to the 
Micro SD card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to 
navigate to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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Fig 5

For our example we will now select the days of the year we would like to generate into standard school days. In the Event 
Groups window select the StandardDay group. Now move your mouse over the calendar and you will notice that the days 
will change to the “StandardDay” group’s colour (In our example this colour is green). Pressing the left mouse button will 
change the highlighted day to this colour and in turn SET the selected day to a standard school day as shown in figure 6 
where February 8th has been selected. We will call this the “Single Day” selecting mode.  To undo the selection press the 
right mouse button on the same day, and the day will become deselected.

Fig 6 
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Now you could go through the entire calendar selecting single days but it would be very time consuming. 
You might also notice that if you hover the mouse over the S,M,T,W,T,F,S letters representing the day of the week, that par-
ticular day will be highlighted for the entire month. We will call this the “Same Day” selecting mode. Press the left mouse 
button on these letters to select that day for the entire month as shown in figure 7, or press the right mouse button on the 
day letter to deselect.

Fig 7

It is also possible to highlight multiple days of the calendar. We will call this the “Multiple Day” selecting mode. Press the left 
mouse button on a day to select it, now hold down the shift key and move the mouse over the calendar. You will notice that 
the selected days will flow over the days and months. For the purposes of our example we will select all days of the calendar 
as shown below (figure 8).

Fig 8
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NOTE: In this mode Saturday and Sunday cannot be selected, unlike in the “Single Day” or “Same Day” selecting modes. It is 
also not possible to deselect multiple days so be sure you have selected the correct days. The easiest way to deselect mutliple 
days is to use the “Same Day” deselection process.

We will now enter all the (Western Australian) school and public holidays, using a combination of “Single Days”, “Same Day 
“ and “Multiple Days” methods. The result is shown below in figure 9.

Fig 9

The basic calendar is now setup for the current year as well as the first two months of next year. At this stage additional Event 
Groups could be added for Student Free days, School Carnivals etc. 

3.0 ADDING EVENTS FOR A GROUP

With the Event Groups setup, we now need to program the events that will occur for these groups.
In our example we will program the events to occur on a standard primary school day. Begin by selecting the StandardDay 
group from the Event Groups window. Next press the “ADD” button below the Events window (just above the Daylight 
Saving window). A New Event window as shown below should appear.

          Fig 10

An event can now be programmed from this window. A description of the event can be added (such as Pre bell, Morning Tea 
etc), the start time and the duration can all be entered. There are 99 output folders available to choose from, which include 
the Bell, Prebell, Music and output folders 5 - 99. These folders contain the audio files to be played on event activation.
The Bell option will play the MP3 audio file in the “Bell” folder of the Micro SD card. 
NOTE: Only one MP3 file is allowed in the “Bell” folder. The remaining folders can have unlimited audio files (depending on 
available storage) and will then randomly play the audio files in the folder any time the corresponding output is activated. 

The last option for the output is the RELAY option, which when used has no audio output, but will activate the “Relay only” 
and “Common” 24V DC switched outputs.
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The first event we will program we will label “PrebellMusic”. We will use this event to play a music track to notify students 
that the first bell will sound soon and that they are to start making their way to their classrooms. Type in the label name, and 
then enter the start time and duration the MP3 is to play. NOTE: The start time is in 24 hour format.
NOTE: The durations for the Prebell, Bell, Music and Relay outputs can all be set to a default time (refer to section 4.0 for 
more information).
We will select the output as the Prebell, so that when this event is activated the MP3 files in the “Prebell” folder of the Micro 
SD card will be played.
NOTE: If more than one MP3 file is in the Prebell folder, then each time this output is activated, a random MP3 audio file  
(from the Prebell folder) will be played.

           Fig 11

Enter all details and then press the “OK” button. The Event should now appear in the events list for the StandardDay group 
as shown below in figure 12.

Fig 12 

The Prebell has been programmed to start at 8:25 AM and play the MP3 file in the “Prebell” folder for five minutes.
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Now let’s repeat the process for the first bell of the day which will occur 
at 8:30AM. We will enter the details as shown in the figure to
the  right. The start time is set to 08:30:00, with a duration of 3 
seconds. The output is set to Bell, which will activate the one and 
only MP3 audio file allowed in the “Bell” folder of the Micro SD card. 

After the details are entered we press OK to confirm, only to receive a error message “Unable to save Event”.

This has occurred because there is an overlap of times. The “PrebellMusic” Event and the “FirstBell” Event overlap at 
08:30:00. If we change the duration of the first event (PrebellMusic) to 4:59, then the first event will finish at 08:59:59 and 
then the overlap is removed.
To change the PrebellMusic Event ,simply highlight this event and press the edit button. The Event window will appear and 
then the changes can be made. Once done, the FirstBell Event can be programmed and saved and will appear in the Events 
list as shown in figure 13.

Fig 13
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To make the programming of the events easier, default durations can be setup for the outputs. For instance you may require 
the Bell to always activate for three seconds. The default duration can be set to 3 seconds and hence whenever the Bell is 
selected as the output for an event, the duration will automatically default to 3 seconds. (Note: This can still be modified to 
any time). To set the defaults refer to section 4.0.

We will now enter the rest of the events for the school day as shown below. The Bell output has been selected for the rest 
of the events for the day, including morning recess, end of recess, lunch, end of lunch and end of the day.

NOTE: If we had an event we wanted to create which was similar to another event already programmed, we could copy this 
event and then make changes. This can be achieved by using the “Duplicate Event” option (refer to section 5.0 for more 
details).

Fig 14

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 

With the events for the Standard School Day entered, its now a matter of entering the events for the other Event groups 
following the same procedure.

Make sure the configuration is saved and then remove the Micro SD card from the Windows based device following win-
dows safe card removal procedures. Make sure the A 4510B is OFF and insert the Micro SD card into the slot in the front; it 
will click when fully inserted. 

The A 4510B can now be switched On. If all is well, after the startup screen is displayed the current time and list of the  
events should be displayed on the screen.

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the Micro SD card, so all configuration information will be saved to the 
Micro SD card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to 
navigate to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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4.0 DEFAULTS

It is possible to change the colour scheme of the programming screen and also set default duration times for each of the 
Bell, Prebell, Music and Relay outputs.
Navigate to the “Edit” menu in the top left corner and select “Defaults...” as shown below in figure 15.

Fig 15

The Defaults window should appear as shown below.

From here the Weekday Cell colour, Weekend Cell colour, Month Tile colour and Day Legend colour can be changed to any 
colour in the full colour spectrum.
The default durations for each of the Bell, Prebell, Music and Relay outputs can also be set here. For our example we will set 
the Prebell duration to 4 minutes and 59 seconds, the Bell duration to 3 seconds and the Music duration to 4 minutes and 
59 seconds as shown below. 
Now whenever we create a new Event the duration of the selected output will default to these settings. 
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5.0 DUPLICATING AN EVENT IN A GROUP

In section 3.0 we illustrated the processes involved in creating the Events for a Group (In this case the StandardDay Group). 
With each of the events the start time, duration and output had to entered manually. 
The programming software has the ability to copy (or duplicate) an event which may speed up the process if similar events 
are to be programmed.

This process will be demonstrated in the following example.
As we programmed for the start of the day with a prebell music event, we will do the same for the call to return to class 
after lunch. An event labelled “EndLunchMus” will sound five minutes before the lunch break finishes to notify the students 
that they should start to make their way back to class. For the output of this event we will use the “Music” output. This will 
use the MP3 files in the music folder of the Micro SD card. This can be useful if a different set of music tracks is required for 
an event.

This event is very similar to the “PrebellMusic” Event we programmed as the first event of the standard day. We will duplicate 
this event and then modify it create an after lunch break event.
Begin by highlighting the “PrebellMusic” Event in the StandardDay Group. Navigate to the “Edit” menu in the top left cor-
ner and then select “Event, Duplicate” as shown in figure 16.

Fig 16

The Duplicate Event window should now appear with the “PrebellMusic” event properties as shown in figure 17.

Fig 17
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We will change the Event name to EndLunchMus and change the start time to five minutes before the end of lunch bell as 
shown in figure 18. We will select the output to the Music folder instead of the Prebell folder as we want to play a series of 
different music files.
NOTE: The Event name can be the same as another event, but the times cannot clash.

Fig 18

The new event now appears in the Event list for StandardDay as shown in figure 19.

Fig 19

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 

NOTE: When the save button is pressed the configuration will be saved to the root directory from which the software was 
run. In our case we ran the software directly from the Micro SD card, so all configuration information will be saved to the 
Micro SD card. If we wish to save the configuration elsewhere we could use the “Save As” option which would allow us to 
navigate to another folder. There is no option to save the configuration with a preferred name.
The configuration file is saved to the CONFIG folder and the event group information is saved to the GROUPS folder.
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6.0 DUPLICATING AN EVENT GROUP

The A 4510B software has a Duplicate Event Group feature which can speed up the programming process. With this func-
tion any Event Group can be duplicated and then edited. 

In the previous examples a standard school day has been programmed into the timer software.
What if Monday’s timetable was different to the other days of the week because every Monday the school has an assembly. 
We could add another Event Group for Monday’s and program the events for the group manually, or we could use the du-
plicate Event Group function to copy the “Standard Day” Group and then modify the event.
The process will be illustrated by the following example.
We begin by selecting the “StandardDay” Event group from the Event groups window.
The duplicate Event Group feature is accessed by navigating to the “Edit” menu in the top left corner and then selecting 
Event group, Duplicate as shown in figure 20.

Fig 20

The Duplicate Event Group window should now appear with
 the “StandardDay” event group properties as shown in 
figure 21.

        Fig 21

Type in a different name, change the colour and then press OK. For our example we will use the name Mondays and change 
the colour to yellow as shown in figure 22.
NOTE: The same name cannot be used for the new Event Group.

        Fig 22
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The New Mondays Event Group created will now appear in the Event Groups as shown in figure 23.

Fig 23

We will then edit the events for the newly created Mondays Event Group and add an assembly at 9:30 am. Finally the rele-
vant school term Monday’s will be selected on the calendar. The result is shown in figure 24.

Fig 24
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7.0 SELECTING THE AUDIO FILES FOR THE OUTPUT FOLDERS

As mentioned previously there are a total of 99 output folders to select from for event playback. To move audio files to these 
folders the “Card Manager” will need to be opened. With the PC software running as outlined in section 1.0, navigate to 
the “File” tab as shown  in figure 25.

Fig 25

Select “Card Manager” and then from the “Browse for Folder” window (figure 26) select the location of the SD card con-
tents, which in our case is Removable Disk (K:) and press OK.
A browsing window should appear as shown in figure 27

  Fig 26

     
      Fig 27
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The output folders are listed on the left side, and the audio files available in the Library, on the right.
From here the audio files in the library, can be dragged into the required folders for the events programmed.

By default the output folders Bell, Music and Prebell should all house an audio file. The timer checks these folders on power 
up, and if any of the relevant folders are empty the timer will not operate.

To check the contents, click on the folders and they should open, and list the audio files inside as shown in figure 28.

Fig 28

To add a file to a folder simply drag the file from the library to the SD card output folders, such as the example shown in 
figure 29 in which the file “Dream of You” is copied to folder 10.

Fig 29
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8.0 ADDING AUDIO FILES TO THE LIBRARY

To add MP3 audio files to the Library, navigate to the “File” tab and select “Card Manager” as outlined in section 3.0.
Press the “Add Files” button and navigate to the location of the MP3 files to be added to the library. In the example below 
the Music folder is selected. Note: The audio files must be of the .MP3 type.

Fig 30

From here a single file, or multiple files as illustrated in figure 31 can be selected.

Fig 31
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Once the required MP3 files are selected press the open button. The selected files should now appear in the Library as 
illustrated in figure 32.

Fig 32

These audio files are now available for use in the output folders.

9.0 RANDOM PLAY OF AUDIO FILES

The timer has the ability to random play audio files, when a particular output is selected for an event. This is available with 
all folders except the Bell folder. These folders can have multiple audio files allocated, which will play randomly when the 
output is activated. In the example illustrated in figure 33, extra audio files are dragged into the Music, Prebell, 7 and 10 
folders.

Fig 33



www.redbackaudio.com.au Redback® Proudly Made In Australia 21

A 4510B Software Programming Guide
10.0 SAVING THE EVENT PROGRAM

Once programming is complete the configuration will need to be saved to the Micro SD card, using the Save or SaveAs 
opions in the File tab. The configuration file will be saved as A4510.cnf. 
If the user wants to keep copies of different programs, the saved file can be accessed on the Micro SD card in the CONFIG 
Folder. Copies can be renamed and left in this folder or moved to another location for recall. Only the filename A 4510.cnf 
will be opened by the software.
With the events now programmed on the Micro SD card, the card can be removed from the PC following windows safe card 
removal procedures. Make sure the timer is OFF and insert the Micro SD card into the slot in the front; it will click when fully 
inserted. 
The timer can now be switched back On. If all is well, after the startup screen is displayed the current time and next event 
should be displayed on the screen.

11.0 REMOTE ACCESS TO THE TIMER

Note: An IT administrator or someone experienced with network protocols wil be required to setup the 
network access. 
With the addition of the A 4498 Connection Pack, the timer can be accessed over an ethernet network (The connection 
details are covered in section 3.0 of the accompanying Timer Instruction Manual and the A 4498 manual).
This will make it possible to edit the timer events program remotely.
Note: MP3 Audio files cannot be added to the library using the remote connection. The Micro SD card needs to be 
removed from the timer and the procedure in section 8.0 followed to add additional files. 

Once the connection has been setup, the PC software will need to be run from a computer with access to the network. 
The software executable file “A4510TIMERPROGRAMMER_XXXX.exe” can be copied from the Micro SD Card and then 
run from the PC. Navigate to the top left corner and press the “Connect” button and the connection window
should appear as shown in figure 34. 

Fig 34

This is where the IP address and port number supplied by the IT administrator are entered. (These were setup when the A 
4498 connection pack was configured). 
Enter the IP address and port number and the default password of 1234 as shown in figure 35. (The password can be 
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changed by editing a text file named PASS.txt which is located on the Micro SD Card. Open the file using a text editor and 
change the password to another 4 digit number). 

Fig 35

If the connection is successful, then the programming screen should look like that shown in figure 36 with the green 
“Timer Enabled” box visible. The connection address and time of connection are shown in the top right corner, and new 
options are now listed on the top left. 
If the connection is not successful there could be a number of reasons which are covered in section 11.0.

Fig 36
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12.0 DOWNLOAD EVENT PROGRAM FROM THE TIMER

In order to make changes to the event program stored in the timer, the configuration file will need to be downloaded from 
the timer. Navigate to and select the “Download Config” tab at the top of the programming window.
A prompt window will appear to confirm the download as shown in figure 37. After downloading the file, the timing 
events will be displayed and can then be edited in exactly the same manner as outlined in sections 2.0 - 6.0.
The file can be saved to the PC at any time, using the Save or Save As functions. If changes are required to the audio out-
put folders, refer to the Manage Audio Files Remotely in section 13.0. If the program is to be uploaded back to the timer 
use the Upload Config option outlined in section 14.0.

Fig 37

13.0 MANAGE AUDIO FILES REMOTELY

The library is accessed by selecting the “Manage Files” tab which will bring up the Remote Card Manager window as 
shown in figure 38. This shows the folders and audio files available on the SD card in the timer. 
The files are simply dragged into the required folders in the same manner as that outlined in section 7.0.
Note: MP3 Audio files cannot be added to the library using the remote connection as the file transfer is too slow. The 
Micro SD card needs to be removed from the timer and the procedures in section 8.0 followed to add additional files. 

Fig 38
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14.0 UPLOAD EVENT PROGRAM TO THE TIMER

The Event Program is uploaded back to the timer, by navigating to and selecting the “Upload Config” tab at the top of 
the programming window. A prompt window will appear to confirm the upload as shown in figure 39. 

Fig 39

The progress bar will display the progress of the upload and a popup window will notify the successful upload.
The timer is now updated with the new Event Program.
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15.0 POSSIBLE REASONS FOR CONNECTION FAILURE

There are a number of scenarios where the timer might not be accessible to the programmign software.

ERROR MESSAGE: No connection available to your device

Fig 40

This error could occur if there is an issue with the physical connections ,or the power to the timer or Serial-To-Ethernet 
Converter. If this error occurs try the following remedies.

Check Timer power   
1) Check the timer has power. If the unit already has power, put the unit into standby mode and then switch back ON. Try 
connecting again.
2) If the unit still doesn’t connect, try removing power from the timer completely by unplgging the power supply. Recon-
nect power and try again.
Check connecting leads:   
1) Check the leads connecting the timer to the adaptor board and D 4231 Serial-To-Ethernet Converter.

Check D 4231 power:   
1) Check that the Serial-To-Ethernet Converter (D 4231) has power. If the unit has power, disconnect and reconnect power 
and try again.

If none of the above remedies work then the error might be because the IP address is incorrect. Check the IP address is 
correct with the IT administrator.
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ERROR MESSAGE: Please enter the correct password

Fig 41

This error will occur when the password entered doesn’t match the password stored in the timer. 
The password can be found in a text file named PASS.txt which is located on the Micro SD Card. 
To change the password open the PASS.txt text file using a text editor and change the password to another 4 digit num-
ber. 

16.0 SYNC TIME

When the timer is connected to the PC through the ethernet connection, the clock time on the timer can be synchronised 
with the PC. The times are visible on the programming window as shown in figure 42. Press the “Sync Time” button to 
sycnhronise the times.

Fig 42
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17.0 DAYLIGHT SAVING

The A 4510B has an optional Daylight Saving mode which is entered through the Programming Software.
In Australia, some of the states have Daylight Saving which begins at 2am on the first Sunday in October when clocks are 
put forward one hour. It ends at 2am (which is 3am Daylight Saving Time) on the first Sunday in April, when clocks are put 
back an hour.
To initiate the Daylight Saving mode, press the “Add” button on the bottom left of the programming screen under the Day-
light Saving Window. The Daylight Saving window should appear as shown below.

From here the dates can be entered. Select the date for the clocks to move forward and then press OK. The date should 
appear in the Daylight Saving window. 

Press the “Add” button again to enter the Daylight Saving window once more and enter the date for the clocks to move 
back an hour and then press OK.
For our example we have selected the dates as shown below.

These dates will then appear as shown in the Daylight Saving window in figure 43.
Daylight Saving mode is now active and will take effect at 2am on the specified dates.  

NOTE: Newer versions of the PC software now have an “Auto add” function in the Daylight Savings Setup.
The software will fill in the dates and times automatically.
The daylight saving dates need to be updated every year, even when the “Auto Add” function is used.

We will save the calendar configuration again by navigating to the “File” menu in the top left corner and selecting “Save”. 
The calendar is now complete.
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 Fig 43

18.0 EDITING THE DATE RANGE

The Start and End dates for the current calendar can be modified by using this function.
Navigate to the “Edit” menu in the top left corner and select “Date range” as shown below in figure 44. 

Fig 44

Once selected, the Change Calendar popup will appear as shown in figure 45. From this screen modify the Start and/or 
End dates and press OK. The updated calendar should now be loaded.

Fig 45
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19.0 BRINGING FORWARD THE DATE

The Start date for the current calendar can be modified by using this function. By using this function new calendars are no 
longer required each year, as the calendar can be continually moved forward months or even years.
Navigate to the “File” menu in the top left corner and select “Bring Forward” as shown below in figure 46.

Fig 46

If Months is selected, the Bring Calendar Forward popup will appear as shown in figure 47. From this screen select the 
number of months to move forward and then press OK. The updated calendar should now be loaded.

Fig 47

The same process is used when bringing forward the Years.
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20.0 NOTES




